Finesse Call Center not Loading
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 27, 2018 - 14:46 PDT
Update
We are continuing to work on a fix for this issue.
Posted 3 months ago. Jun 27, 2018 - 14:44 PDT
Update
We are continuing to work on a fix for this issue.
Posted 3 months ago. Jun 27, 2018 - 14:43 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Jun 27, 2018 - 14:38 PDT
This incident affected: Finesse (Call Center).