HCM is currently unavailable.
Incident Report for SJSU System Status
Resolved
The Human Resources and Student Affairs pages have intermittent connectivity.
Posted May 15, 2015 - 09:39 PDT
Investigating
The Human Resources and Student Affairs pages are not accessible.
Posted May 15, 2015 - 09:37 PDT