Finesse Call Centers are down.
Incident Report for SJSU System Status
Resolved
This incident has been resolved.
Posted Jun 14, 2021 - 19:01 PDT
Investigating
We are currently investigating this issue.
Posted Jun 14, 2021 - 15:40 PDT
This incident affected: Infrastructure (Finesse (Call Center)).