Canvas
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 31, 2018 - 11:33 PDT
Investigating
We are currently experiencing degraded performance of our Canvas application.
Posted 5 months ago. Jul 30, 2018 - 11:05 PDT
This incident affected: Canvas Learning Mgt System.