The Student Account Online store is down. Cashnet is not posting properly.
Incident Report for SJSU System Status
Resolved
This incident has been resolved.
Posted May 21, 2019 - 10:15 PDT
Investigating
We are currently investigating this issue.
Posted May 20, 2019 - 10:30 PDT
This incident affected: Infrastructure (CashNet (Student Account Home)).