iSupport - intermittent response time
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 27, 2018 - 10:20 PST
Investigating
We are currently investigating this issue.
Posted 4 months ago. Feb 27, 2018 - 08:43 PST
This incident affected: iSupport Help Desk Ticketing System.