PeopleSoft
Incident Report for SJSU System Status
Resolved
This incident has been resolved.
Posted Mar 26, 2020 - 11:58 PDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 26, 2020 - 11:58 PDT
Identified
MySJSU is having performance issues and will be available shortly.
Posted Mar 26, 2020 - 11:40 PDT
This incident affected: SJSU IT-Enterprise Solution (MySJSU (PeopleSoft)).