Phone Service and Internet are down in the Student Services Center
Incident Report for SJSU System
Resolved
The issue has been resolved and phones and Internet access are back to normal.
Posted 5 months ago. Jun 26, 2017 - 09:45 PDT
Investigating
We are investigating reports that the phones and Internet are down in SSC.
Posted 5 months ago. Jun 26, 2017 - 08:58 PDT
This incident affected: Voice and Video Communication Systems.