iSupport is currently unavailable.
Incident Report for SJSU System
Resolved
The issue has been resolved and the system is now available.
Posted 8 months ago. Feb 03, 2017 - 08:27 PST
Investigating
The iSupport ticketing system is currently down.
Posted 8 months ago. Feb 03, 2017 - 08:19 PST
This incident affected: iSupport Help Desk Ticketing System.