Finesse Call Centers are not available. We are investigation the issue
Incident Report for SJSU System
Resolved
The issue has been resolved and all call centers are now fully functional.
Posted 5 months ago. Jun 07, 2017 - 14:07 PDT
Investigating
Finesse call centers are currently unavailable.
Posted 5 months ago. Jun 07, 2017 - 13:15 PDT
This incident affected: Voice and Video Communication Systems.