Moss Landing Phones are currently down
Incident Report for SJSU System
Resolved
The issue has been resolved and phones are now operational.
Posted 21 days ago. Jun 01, 2017 - 06:50 PDT
Investigating
Phones at Moss Landing are down. We are working to resolve the issue
Posted 22 days ago. May 31, 2017 - 13:26 PDT
This incident affected: Voice and Video Communication Systems.