MySJSU - Down
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 8 months ago. Nov 07, 2018 - 09:55 PST
Investigating
We are currently investigating this issue.
Posted 8 months ago. Nov 07, 2018 - 07:43 PST
This incident affected: One.SJSU, MySJSU (PeopleSoft), and SJSU @ Work.