Open University Sign in link
Incident Report for SJSU System Status
Resolved
This incident has been resolved.
Posted Dec 16, 2014 - 11:08 PST
Investigating
The Open University sign in link is currently only working with the Chrome browser. Internet Explorer and Firefox are not functioning.
Posted Dec 08, 2014 - 15:02 PST