iSupport Portal not loading
Incident Report for SJSU System Status
Resolved
This incident has been resolved.
Posted Nov 14, 2019 - 08:42 PST
Investigating
We are currently investigating this issue.
Posted Nov 14, 2019 - 07:44 PST
This incident affected: Applications (iSupport Help Desk Ticketing System).