Finesse System
Incident Report for SJSU System
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 30, 2018 - 14:09 PDT
Investigating
The Finesse System is down.
Posted 3 months ago. Aug 30, 2018 - 13:10 PDT
This incident affected: Finesse (Call Center).