Google Drive is currently unavailable
Incident Report for SJSU System Status
Resolved
Google is reporting that the issue has been resolved.
Posted Jan 17, 2017 - 13:07 PST
Investigating
Google is currently unavailable. Google is working on the issue.
Posted Jan 17, 2017 - 10:00 PST
This incident affected: Applications (SJSU Google Workspace).