Password reset is currently unavailable.
Incident Report for SJSU System
Resolved
Password reset is now available.
Posted 11 days ago. Dec 06, 2017 - 08:46 PST
Investigating
Password reset is currently unavailable. We are working to resolve the issue.
Posted 11 days ago. Dec 06, 2017 - 08:22 PST
This incident affected: SJSUOne (Identity Mgt and Authorization).